API Express service tests OK but doesn't receive data when used

The Announcement category is used for Appery.io-related updates and new releases
property123
Posts: 1
Joined: Fri Jun 04, 2021 4:11 am

API Express service tests OK but doesn't receive data when used

Post by property123 »

Hi,

I've set up an API Express project, tested it and it's all good. Works lovely and returns values from the RESTAPI built in to it.

I've imported the service into my app and tested it and all looks good...it's returning data when I test it (on the TEST section of the SERVICE) that looks like this in the test window....

[{
"CHEMICAL_SUBSTANCE": "SubstanceA"
}, {
"CHEMICAL_SUBSTANCE": "SubstanceB"
}, {
"CHEMICAL_SUBSTANCE": "SubstanceC"
}, {.........etc

it returns a few hundred results as it should.

All good so far.

When I call the service in the app and pass the correct parameter (I've checked that the parameter is being passed correctly by logging it in the console then pasting it into the test section of the service with success) then it does not return ANY data. Just an empty array.

I'm running the following on the Success event of the service:

console.log("DataLength: " + data.length);
Apperyio.storage.MedList.set(data);

but data length is coming out as "0" and the storage variable (which is set up in the Model as the same structure as the response) is just an empty array.

Serhii Kulibaba
Posts: 149
Joined: Tue Aug 27, 2013 1:47 pm

Re: API Express service tests OK but doesn't receive data when used

Post by Serhii Kulibaba »

Hello,

Could you please provide us with more details? Please provide us (support@appery.io) with a backup of that API Express service to test it on our side

Post Reply