Problem with HTML component.

Moderator: Support

ZermattMan
Posts: 10
Joined: Thu Aug 27, 2020 4:22 am

Problem with HTML component.

Post by ZermattMan »

I am trying to show a field from a table, in an HTML componenent,

I have followed the example in the RSS project. Declaring the field as an HTML, and setting class to appiery-html.
The table is read and displayed, but the HTML field shows as text with the html characters on display.

Any help would be appreciated

ZermattMan


Serhii Kulibaba
Posts: 86
Joined: Tue Aug 27, 2013 1:47 pm

Re: Problem with HTML component.

Post by Serhii Kulibaba »

Hello,

Could you please provide us with more details, screenshots, or exact steps to reproduce this problem?


ZermattMan
Posts: 10
Joined: Thu Aug 27, 2020 4:22 am

Re: Problem with HTML component.

Post by ZermattMan »

Please accept my apologies for the poor details!

The attached screenshots show the definition of my HTML component and the resulting display.

Image

Attachments
2020-11-03 (2).png
2020-11-03 (2).png (208.84 KiB) Viewed 425 times
2020-11-03 (3).png
2020-11-03 (3).png (110.77 KiB) Viewed 425 times

Serhii Kulibaba
Posts: 86
Joined: Tue Aug 27, 2013 1:47 pm

Re: Problem with HTML component.

Post by Serhii Kulibaba »

It seems you have set it in the tab "WYSIWYG", not "HTML Source". Please use exactly "HTML Source" for that


ZermattMan
Posts: 10
Joined: Thu Aug 27, 2020 4:22 am

Re: Problem with HTML component.

Post by ZermattMan »

I am inputting it from a table. How do I map it to the tab you mentiion?


Serhii Kulibaba
Posts: 86
Joined: Tue Aug 27, 2013 1:47 pm

Re: Problem with HTML component.

Post by Serhii Kulibaba »

Could you please provide us with more details, screenshots or exact steps to reproduce this problem?


ZermattMan
Posts: 10
Joined: Thu Aug 27, 2020 4:22 am

Re: Problem with HTML component.

Post by ZermattMan »

You can see how I map my field "Description" to the HTML field on my page.
How do I map it as HTML and not text?

Attachments
2020-11-10.png
2020-11-10.png (207.3 KiB) Viewed 221 times

Serhii Kulibaba
Posts: 86
Joined: Tue Aug 27, 2013 1:47 pm

Re: Problem with HTML component.

Post by Serhii Kulibaba »

Yes, the mapping is correct. What value exactly does your property "Description" have?


ZermattMan
Posts: 10
Joined: Thu Aug 27, 2020 4:22 am

Re: Problem with HTML component.

Post by ZermattMan »

Description is a field from a table. It contains HTML. You can see it in the second attachment, above.

It starts ::""Father taken as a POW at Dunkirk..."


Serhii Kulibaba
Posts: 86
Joined: Tue Aug 27, 2013 1:47 pm

Re: Problem with HTML component.

Post by Serhii Kulibaba »

Could you please provide us with a screenshot of that value from the database? It might have the safe HTML codes, not a real HTML layout: https://www.obkb.com/dcljr/charstxt.html

Please provide us with a public app link (https://docs.appery.io/docs/testingande ... app-public) and exact steps to reproduce this problem.


Post Reply