Android - API level to at least 29

Moderator: Support

jprefer
Posts: 1
Joined: Mon Jul 27, 2020 10:56 pm

Android - API level to at least 29

Post by jprefer »

Hi,
I tried uploading my app to the Google Play store and received this error:
Upload failed
Your app currently targets API level 24 and must target at least API level 29 to ensure it is built on the latest APIs optimized for security and performance. Change your app's target API level to at least 29.

Screen Shot 2020-08-04 at 4.37.02 PM.jpg
Screen Shot 2020-08-04 at 4.37.02 PM.jpg (84.39 KiB) Viewed 623 times

I have checked the Android Binary settings tab and found that I have Target SDK version - Android 10 with a Min. SDK version - Android 7

Screen Shot 2020-08-04 at 4.41.57 PM.jpg
Screen Shot 2020-08-04 at 4.41.57 PM.jpg (26.91 KiB) Viewed 623 times

I have also checked the config.xml and found that it was set to "24", I changed it to 29 but it didn't make a difference. (I have put it back to 24):

Screen Shot 2020-08-04 at 4.43.23 PM.jpg
Screen Shot 2020-08-04 at 4.43.23 PM.jpg (46.39 KiB) Viewed 623 times

My libraries version is v2.1

Any help would be greatly appreciated.

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Re: Android - API level to at least 29

Post by Serhii Kulibaba »

Hello,

Please delete the edited (blue colored) files on the Source tab and click Undo all source changes on the folder with the edited files.

Please note that functionality added via the Source tab will be lost and you would need to edit source files again in order to add it back, thus we would recommend that you save the project backup before this operation.

Here (https://docs.appery.io/docs/appbuilder- ... de-editing) is more information about Source files editing.

Post Reply