JQM: Appery Inapp Browser does not work

Moderator: Support

anywhere
Posts: 40
Joined: Tue Sep 08, 2020 3:04 am

JQM: Appery Inapp Browser does not work

Post by anywhere »

When doing window.open(some url, _system) the url is not displayed within the app like it did in the past. A seperate browser session is opened.

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

Re: JQM: Appery Inapp Browser does not work

Post by Evgene Karachevtsev »

Hello,

Could you please specify if you get any errors in a browser console when you test this feature?

Chris..
Posts: 9
Joined: Sun Oct 18, 2020 10:33 am

Re: JQM: Appery Inapp Browser does not work

Post by Chris.. »

Just wondering if you found a solution to this problem. None of my '_system' links are opening in the system browser (Safari) on iOS devices.

I've tried using both:

Code: Select all

cordova.InAppBrowser.open(url, target, options);

and

Code: Select all

window.open(url, target, options);

(with

Code: Select all

window.open = cordova.InAppBrowser.open;

run on deviceready)

as outlined in the Cordova documentation, but neither works.

I'm running Cordova iOS 6.1.1 and InAppBrowser 4.0.0.

Thanks,

Chris

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Re: JQM: Appery Inapp Browser does not work

Post by Serhii Kulibaba »

Hello,

Please check all of these types of browsers:
_self
_blank
_system

_blank should open the inAppBrowser here

Chris..
Posts: 9
Joined: Sun Oct 18, 2020 10:33 am

Re: JQM: Appery Inapp Browser does not work

Post by Chris.. »

Shortly after posting this, I discovered a change to a source file was the cause of the problem. However, I couldn't find where to delete my pending post.

Thanks all the same for the reply!

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Re: JQM: Appery Inapp Browser does not work

Post by Serhii Kulibaba »

Glad to hear things are sorted out now!

Post Reply