REST api works using API Express but not when set up as a Service

Moderator: Support

Andrew6784445
Posts: 1
Joined: Fri Apr 04, 2014 2:08 pm

REST api works using API Express but not when set up as a Service

Post by Andrew6784445 »

I have created a REST api using NodeJS running on MacOS using http AND https.

I am able to create a service that successfully connects to my API using https and returns JSON when using the appery "Test". I can access my REST api using Postman and any web browser.

Unfortunately I cannot get the mapping to display results.

I have tried directly mapping the object to a List and I have tried mapping to a variable first, then to the List. In all cases, my REST api shows that the request is being filled but I am not seeing anything populate the List.

If I create an APIExpress Service that does nothing but call my REST api, it works and displays as desired.

Is there something else that I need to do to connect to my REST api without going through APIExpress?

Serhii Kulibaba
Posts: 145
Joined: Tue Aug 27, 2013 1:47 pm

Re: REST api works using API Express but not when set up as a Service

Post by Serhii Kulibaba »

Hello,

You didn't need to call it with the API Express, you can call it directly from the application. Just create the REST service for that. Create new -> Service -> REST service

Please run it on the test tab of the service to see the response. Kindly provide us with the screenshot of the request and the response from that test tab

Post Reply