API Level 19

This forum contains topics that were moved from Get Satisfaction
M&M
Posts: 0
Joined: Tue Nov 11, 2014 6:59 am

API Level 19

Post by M&M »

hi,

Is it possible / ok to set the API level to 19 ( Kit kat 4.4 I guess). Some additional things like being able to turn off default NFC sound can be done in that version.

If yes then how do we do this?

Thanks,
M&M

Alena Prykhodko
Posts: 0
Joined: Tue Apr 09, 2013 7:36 am

API Level 19

Post by Alena Prykhodko »

Hello,

We do not support external plugins and do not have ready solution to share.
Please search online whether it's possible and how this should be implemented..

M&M
Posts: 0
Joined: Tue Nov 11, 2014 6:59 am

API Level 19

Post by M&M »

Hi,

I am not referring to external plugins. I am.referring to Android API level. I think current default level when you choose 4.1 version, it is 16. But how then lot of newer java code requires android api level 19

Thanks,
M&M

M&M
Posts: 0
Joined: Tue Nov 11, 2014 6:59 am

API Level 19

Post by M&M »

I am not trying to ask for help regarding external plugins - I am referring to ANDROID API level. I hope the attached image clarifies what I am trying to ask

Image

I can see that android manifest file has api / sdk level set to 16 (version 4.1) .

Yurii Orishchuk
Posts: 0
Joined: Fri Feb 14, 2014 8:20 am

API Level 19

Post by Yurii Orishchuk »

HI M&M,

To set android 2.2 version available you can do following:

1 Open project sources.

2 Open file : ANDROID-projectName-AndroidManifest.xml
Details: http://prntscr.com/7mwfpg/direct

3 Edit following line:

precode

<uses-sdk android:minSdkVersion="16" android:targetSdkVersion="16"/>

/code/pre

To set android:minSdkVersion with 8 value(android 2.2+).

Details: http://prntscr.com/7mwh4g/direct

It such way you can set any other min sdk verstion.

Regards.

M&M
Posts: 0
Joined: Tue Nov 11, 2014 6:59 am

API Level 19

Post by M&M »

hi Yurii,

Thanks a lot. I just needed to confirm that.

Cheers,
M&M

M&M
Posts: 0
Joined: Tue Nov 11, 2014 6:59 am

API Level 19

Post by M&M »

hi Yurii,

Are there any simple steps to add google play services dependency in Appery? So far I could not get any help on this topic. I need it because my other plugins need this as a dependency - for example admob and other geofencing plugin.

I have seen it being referenced this way
code
<framework src="com&#46;google&#46;android&#46;gms:play-services-location:7&#46;5&#46;0" />
/code

I believe the above is the newer way. The other methods are deprecated or will be deprecated soon I heard

thanks

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

API Level 19

Post by Evgene Karachevtsev »

M&M,

No, unfortunately there are not simple steps to add them. They should be add like any other plugin.

M&M
Posts: 0
Joined: Tue Nov 11, 2014 6:59 am

API Level 19

Post by M&M »

Everything from advertisements to important geolocation APIs are dependent on the below line

code
<framework src="com&#46;google&#46;android&#46;gms:play-services-location:7&#46;5&#46;0" />
/code

The only revenue for our App is from advertising and we cannot use the advertisement plugin without Google Play services.

Post Reply