Target API level requirements from August 2018

This forum contains topics that were moved from Get Satisfaction
Bernie
Posts: 0
Joined: Fri Jul 27, 2012 2:06 pm

Target API level requirements from August 2018

Post by Bernie »

I do receive the following warning message when setting up a new Android release in the playstore:

Warning:

Your app currently targets API level 24 and must target at least API level 26 to ensure it is built on the latest APIs optimized for security and performance.

From August 2018, new apps must target at least Android 8.0 (API level 26).
From November 2018, app updates must target Android 8.0 (API level 26).

Tip:

Change your app's target API level. Learn how.

Will this be taken care of, soon?
When can we expect the support of Android 8?

Thank you in advance.

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

Target API level requirements from August 2018

Post by Evgene Karachevtsev »

Hello Bernie,

We have passed this info to our development team and will get back to you with the update soon.

Bernie
Posts: 0
Joined: Fri Jul 27, 2012 2:06 pm

Target API level requirements from August 2018

Post by Bernie »

Sounds good

Bernie
Posts: 0
Joined: Fri Jul 27, 2012 2:06 pm

Target API level requirements from August 2018

Post by Bernie »

Any news on this one?

Galyna Abramovych
Site Admin
Posts: 68
Joined: Tue Mar 22, 2016 6:03 pm

Target API level requirements from August 2018

Post by Galyna Abramovych »

Hello,

We are planning to introduce this support with our nearest release which is in about a month or so.

Ayelmer Veenstra
Posts: 0
Joined: Fri Jul 06, 2018 4:05 pm

Target API level requirements from August 2018

Post by Ayelmer Veenstra »

Great,
Is there a release date available?
August is in 3 1/2 weeks?

Galyna Abramovych
Site Admin
Posts: 68
Joined: Tue Mar 22, 2016 6:03 pm

Target API level requirements from August 2018

Post by Galyna Abramovych »

Hi,

Unfortunately, we cannot announce the release date right now.
We will do it a bit later.

Illya Stepanov
Posts: 0
Joined: Mon Mar 18, 2013 8:48 am

Target API level requirements from August 2018

Post by Illya Stepanov »

The new Android SDK 8.1 (API level 27) is now available in Appery.io App Settings, you can now submit your binary APK files to Google Play Store with all met requirements. Image

sim ge
Posts: 0
Joined: Wed Apr 06, 2016 7:42 am

Target API level requirements from August 2018

Post by sim ge »

I Image

I'm having problem setting a higher target SDK version.

Illya Stepanov
Posts: 0
Joined: Mon Mar 18, 2013 8:48 am

Target API level requirements from August 2018

Post by Illya Stepanov »

Please specify what is the libraries version of your app?
You can change the SDK version only after changing the libraries version to the latest under App settings Resources Libraries version.

Post Reply