Admob not working in Library Version

This forum contains topics that were moved from Get Satisfaction
Vinny B
Posts: 0
Joined: Fri Aug 22, 2014 2:22 pm

Admob not working in Library Version

Post by Vinny B »

I'm trying to create an APK with the Cordova Plugin Admob Pro.

If I set appery Library version 3.1 I can create an APK

if I set appery Library version to 4.0 or 4.1 the APK fails with no errors.

If I create the APK WITHOUT the Admob Pro plugin using lobrary version 4.0 or 4.1 then it works fine but then there are no ads.

Any Ideas?

Thank you
Vinny

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

Admob not working in Library Version

Post by Evgene Karachevtsev »

Hello Vinny,

Could you please check that you are using the version of the plugin that is compatible with Appery.io Cordova library version?

Vinny B
Posts: 0
Joined: Fri Aug 22, 2014 2:22 pm

Admob not working in Library Version

Post by Vinny B »

I don’t think ANyBoDy lists Appery.io.io library version in there compatibility.

He is what they list:

Cordova Plugin for Google AdMob and DFP. Easy use, show mobile Ad with single line of JavaScript. Compatible with Cordova CLI, PhoneGap Build, Intel XDK/Crosswalk, Google ChromeApp, I

Here is the link to them:

.https://github.com/floatinghotpot/cor...

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

Admob not working in Library Version

Post by Evgene Karachevtsev »

Dear Vinny,

Could you please clarify does your app works correctly with the Library version 3.1 and this plugin?

Vinny B
Posts: 0
Joined: Fri Aug 22, 2014 2:22 pm

Admob not working in Library Version

Post by Vinny B »

cvdvdsvs

Vinny B
Posts: 0
Joined: Fri Aug 22, 2014 2:22 pm

Admob not working in Library Version

Post by Vinny B »

Yes it works fine with library version 3.1

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

Admob not working in Library Version

Post by Evgene Karachevtsev »

Dear Vinny,

Actually, Cordova plugins are outside the scope of our support, but we'll try to help you. Most likely this version of the plugin won't be working correctly with updated Appery.io libraries as it is working with the previous version. Please try to search for the updated version of the plugin or some analog. There could be some conflict between this Cordova plugin and default Cordova plugins used in your app, please check that you are using the latest versions of them. You may try to disable them one by one to check whether the case is in one of them.
You may also consider purchasing Advisory Pack to get more in-depth help on this question. Here is more information about it: http://appery.io/services/#Advisory_Pack

Vinny B
Posts: 0
Joined: Fri Aug 22, 2014 2:22 pm

Admob not working in Library Version

Post by Vinny B »

Forget about this problem. Can you fix the problem of my home button not working on your test app ?

redwhiteblue4free
Posts: 0
Joined: Tue Jul 04, 2017 6:37 am

Admob not working in Library Version

Post by redwhiteblue4free »

hi Vinny B

im also trying to get admob working in appery but dont know how.

if you know how can you tell me?

thanks

Vinny B
Posts: 0
Joined: Fri Aug 22, 2014 2:22 pm

Admob not working in Library Version

Post by Vinny B »

Since Appery no longer works with the Plugin I do not know if you can get it to work . unless you use the old Library version 3.1.

Currently I cannot push any updates using the play store because of this issue.

When you use Appery to create apps you will learn that when updates are needed there usually 2 months behind which is acceptable I guess.

Eventually 3.1 will be discontinued and the plugin will not work, meaning ADmob will not work.

I suggest you wait until they push there next update and maybe it will solve this issue.

You will also learn this phrase "outside the scope of our support"

In the mean times if you want to try with version 3.1 I will be more than happy to assist you.

The first thing to do is ALWAYS test your app on an ANDROID device installing the APK. While trying to run ads.

Make sure you have signed up to Admob and accepted all the terms of service and what not. ALSO YOU CREATED Ads to run and put your APP name correctly.

Download zip file from : https://github.com/floatinghotpot/cor...

add is to Appery RESOURCES - Cordova Plugins

is you app Select the Plugin

Turn off ALL other PLUGINS THAT ARE NOT NEED.

In android Permission you will need LOCATION Services, internet, network

On you START PAGE add and event on DEVICE READY - Javascript

Replace with your number in banner and interstella.

var admobid = { banner: 'ca-app-pub-?????????????????', interstitial: 'ca-app-pub-??????????????????' };

AdMob.createBanner( { adId: admobid.banner, position: AdMob.AD_POSITION.BOTTOM_CENTER, autoShow: true } );

Post Reply