You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

This forum contains topics that were moved from Get Satisfaction
SteveLacy
Posts: 4
Joined: Fri Apr 20, 2012 11:54 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by SteveLacy »

I just got an email from the Google Play store saying several of my apps are built on a version of Apache Cordova that contains security vulnerabilities. These apps were developed with Appery.io.

Their instructions are "You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible. For more information about the vulnerabilities, and for guidance on upgrading Apache Cordova, please see http://cordova.apache.org/announcemen...."

I see that even the newly released version of Appery.io is only at 3.3.0.

The announcement goes on to say "Please note, applications with vulnerabilities that expose users to risk of compromise may be considered “dangerous products” and subject to removal from Google Play."

Is there a plan in place for this issue?

Thanks,

Steve

Sjef Moling
Posts: 0
Joined: Thu Jan 23, 2014 10:00 am

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Sjef Moling »

same here

Michael4771079
Posts: 0
Joined: Sat Jul 21, 2012 2:03 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Michael4771079 »

also got this email

Marcel LeBrun
Posts: 0
Joined: Wed Apr 16, 2014 4:18 am

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Marcel LeBrun »

I also received this email. It seems Google Play may remove any app that does not upgrade to 3.5.1. Since the app is built on appery.io, what is the process to upgrade and address the security vulnerability?

mjalvarezglez
Posts: 0
Joined: Wed Oct 01, 2014 5:00 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by mjalvarezglez »

The same!

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Hnto7127371 »

Same here

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Evgene Karachevtsev »

Hello!

We'll add Cordova 3.6 in mini-release which should be about in week or two.

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Hnto7127371 »

Evgene,

In the old and new builder? Or just in the new builder?

Off topic:
When will the old builder be deleted? Is there a specific date?

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Evgene Karachevtsev »

Hnto,

We are going to support old builder for now, not sure if updated version will support old builder. I sent this question to our development team and will get back with the accurate information when have update from them.

Maurice
Posts: 0
Joined: Sun Mar 23, 2014 5:25 pm

You should upgrade to Apache Cordova 3.5.1 or higher as soon as possible

Post by Maurice »

Hi Evgene
I have also just got this email from Google. It says I "should upgrade to Apache Cordova 3.5.1 or higher as soon as possible."
I went onto Appery and I have upgraded my app to the new builder, but how do I now upgrade Apache? Please get back soon as Google is threatening to remove my app as the above users have said.
Many thanks

Post Reply