Devices not registering in database(again)

This forum contains topics that were moved from Get Satisfaction
Tom7044357
Posts: 0
Joined: Thu Aug 14, 2014 4:58 pm

Devices not registering in database(again)

Post by Tom7044357 »

Hello,

Everytime i make a new app and i want to use pushnotifications i have a problem with devices not registering in the database. Sometimes it works out of nowhere but this time it doesn't work at all.

I've enabled the Cordova plugins: Device, Notification and PushPlugin. I've added a fresh Google Services JSON File and Firebase Admin SDK JSON File while also linking a database and enabling push notification in settings.

I'm getting a little bit sad of how unclear it can be to make Appery add devices to the database when you install it on your mobile phone.

Also, when i click "Learn more" beneath the Google Services JSON File button i get redirected to a 403 forbidden page, which is just bad in my opinion. Either create the page or remove the redirect link.

Do you have a solution for my problem?

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Devices not registering in database(again)

Post by Serhii Kulibaba »

Hello Ron,

What libraries version do you use in the project? Have you installed the app to the device after all these settings?

Tom7044357
Posts: 0
Joined: Thu Aug 14, 2014 4:58 pm

Devices not registering in database(again)

Post by Tom7044357 »

Hello Serhii,

I use libraries version 5.0. I have reinstalled the app multiple times on my device after every change i made.

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Devices not registering in database(again)

Post by Serhii Kulibaba »

Please [share] (https://docs.appery.io/docs/teams-sha...) your app with a href="mailto:support@appery.io" rel="nofollow"support@appery.io/a and provide us with the following information:

1) App name
2) JSON config file, which you use in the push notifications tab

Tom7044357
Posts: 0
Joined: Thu Aug 14, 2014 4:58 pm

Devices not registering in database(again)

Post by Tom7044357 »

Done

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Devices not registering in database(again)

Post by Serhii Kulibaba »

Thank you, let's continue the discussion in the ticket #37964

Post Reply