Reponse area one item error

This forum contains topics that were moved from Get Satisfaction
Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

Hello,

I have a problem when iterating through a response that did work before in the old builder. The error I'm receiving is:
codeError: Attempt to access Object by index: i/code

It only happens when the response returns only one item, when there are two or more items returned, everything works fine.

This is my reponse:
Image

I've read other topics in which you say that XML works like this because it's an array and when one item is returned it doesn't work, but why did it work in the old builder?
Am I doing something wrong in this new builder?

Thank you

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

This is my mapping:

Image

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

Anyone?

Illya Stepanov
Posts: 0
Joined: Mon Mar 18, 2013 8:48 am

Reponse area one item error

Post by Illya Stepanov »

Hi -

It's hard to say what could be wrong here, as we don't know the structure of your XML data.

It could the type of data in your array, now it is an 'Object' and what would be if you change it to a 'String'?

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

The structure of my XML is as follow:

code
<cartlines>
<prijs_totaal>VALUE</prijs_totaal
<aantal_totaal>VALUE</aantal_totaal>
LOOP
{
<line>
<name>VALUE</name>
</line>
}
</cartlines>
/code

I'm wondering why this worked perfectly in the old builder but now it doesn't.
Does it hage anything to do with the new MVC structure?

Yurii Orishchuk
Posts: 0
Joined: Fri Feb 14, 2014 8:20 am

Reponse area one item error

Post by Yurii Orishchuk »

Hi Hnto,

Unfortunatly it's know bug, we working on it..

Here is main thread for this:
https://getsatisfaction.com/apperyio/...

Regards.

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

Hello Yurii,

Is it known when this bug will be fixed? A specific date?

Thank you.

Maryna Brodina
Posts: 0
Joined: Thu Apr 05, 2012 7:27 am

Reponse area one item error

Post by Maryna Brodina »

Hello!

Unfortunately it is not included in upcoming release.

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

Hello Maryna,

That's very unfortunate!

Is there a workaround for this? The link that Yurii has provided does not help me.

Thank you.

Hnto7127371
Posts: 0
Joined: Wed Sep 24, 2014 10:21 pm

Reponse area one item error

Post by Hnto7127371 »

Hello,

This problem has to be fixed ASP!
This is not an error we can ignore. I've had to delay 3 apps because of this error and of the freeze error in the builder.

I have found workarounds for this error, but it's still a temporary error.

It's unacceptable to leave these errors for another month or so without fixing them. We're paying money for a builder that has to work accordingly.

Please notify the developers to fix these issues asp. It's hindering, I'm pretty sure, a lot of appery developers here.

Thank you.

Post Reply