Upgrade to Android 8.0 breaks push

This forum contains topics that were moved from Get Satisfaction
Chris6743166
Posts: 1
Joined: Tue Mar 18, 2014 11:50 am

Upgrade to Android 8.0 breaks push

Post by Chris6743166 »

Hi,

When I update an app to Android 8.0 (from 7.0), push stops working on Android. I've made no other changes.

When a push is sent, I get the following message on the app "Cynllaith keeps stopping".

The app is shared with support. It's called Bro Cynllaith (23a2336a-e321-4627-a7f0-654b5ae472db)

Can you help?

Thanks,

Chris

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Upgrade to Android 8.0 breaks push

Post by Serhii Kulibaba »

Hello,

You use the Push plugin with a version 1.8.4
Please select the last one (2.1.2)

Chris6743166
Posts: 1
Joined: Tue Mar 18, 2014 11:50 am

Upgrade to Android 8.0 breaks push

Post by Chris6743166 »

Thanks for the reply. I have already tried that, but got this build error:

pre
(node:26286) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): Error: /app/platforms/android/gradlew: Command failed with exit code 1 Error output:
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

FAILURE: Build failed with an exception.
/pre

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Upgrade to Android 8.0 breaks push

Post by Serhii Kulibaba »

Have you enabled Push Notifications using your Firebase project?
Please see the step-by-step tutorial here:
https://docs.appery.io/docs/pushnotif...

Chris6743166
Posts: 1
Joined: Tue Mar 18, 2014 11:50 am

Upgrade to Android 8.0 breaks push

Post by Chris6743166 »

Thanks Serhii. That was the problem.

Chris

Rodrigo9910066
Posts: 0
Joined: Thu Jan 10, 2019 12:00 am

Upgrade to Android 8.0 breaks push

Post by Rodrigo9910066 »

Hello,
I'm getting a similar error. I am using the PushPlugin 2.1.3 and set up Push Notifications using my Firebase project. However, I am getting this error when I try to export:


/app/platforms/android/src/com/adobe/phonegap/push/FCMService.java:74: error: cannot access zzbej
String from = message.getFrom();
^
class file for com.google.android.gms.internal.zzbej not found
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /app/platforms/android/src/com/adobe/phonegap/push/PushPlugin.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error
:compileDebugJavaWithJavac FAILED

FAILURE: Build failed with an exception.
/app/platforms/android/src/com/adobe/phonegap/push/FCMService.java:74: error: cannot access zzbej
String from = message.getFrom();
^
class file for com.google.android.gms.internal.zzbej not found
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /app/platforms/android/src/com/adobe/phonegap/push/PushPlugin.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error

FAILURE: Build failed with an exception.


Please help.

Thanks,
Rodrigo

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Upgrade to Android 8.0 breaks push

Post by Serhii Kulibaba »

What project type (JQM or Ionic) do you use here?
What libraries' version is selected?
Have you uploaded JSON config files of your Firebase account to Appery.io Push Notifications settings tab?

Rodrigo9910066
Posts: 0
Joined: Thu Jan 10, 2019 12:00 am

Upgrade to Android 8.0 breaks push

Post by Rodrigo9910066 »

Hi Serhii,
It's an Ionic (1) app with v2.0 libraries.
Yes, I uploaded the JSON config files of my Firebase account to Appery.io.

Thanks,
Rodrigo

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Upgrade to Android 8.0 breaks push

Post by Serhii Kulibaba »

Please be sure you have selected the latest libraries version (the version 2.1 is available)

Also, please check the following Cordova plugins (all of them must be enabled)
PushPlugin 2.2.3
Notification 2.0.1
Device 2.0.2

Rodrigo9910066
Posts: 0
Joined: Thu Jan 10, 2019 12:00 am

Upgrade to Android 8.0 breaks push

Post by Rodrigo9910066 »

I changed to libraries v2.1 and activated Notification 2.0.1 and Device 2.0.2, and kept PushPlugin 2.2.3.

Now I get a different error:
"BUILD FAILED in 8s
Build step 'Execute shell' marked build as failure"

I have shared the app with support. Name of the app: TEST04

Thanks,
Rodrigo

Post Reply