db service not working after upgrade

This forum contains topics that were moved from Get Satisfaction
Lux Smith
Posts: 0
Joined: Fri Jan 10, 2014 4:52 am

db service not working after upgrade

Post by Lux Smith »

I have 3 columns defined in the db that are of type "pointer". I have a create db service that creates a record with one of the three columns populated. I am now getting an error that the other two pointer columns are not populated with values. The service was working fine before the upgrade.

Illya Stepanov
Posts: 0
Joined: Mon Mar 18, 2013 8:48 am

db service not working after upgrade

Post by Illya Stepanov »

Hi Lux,

Could you please clarify what error message do you get?

Lux Smith
Posts: 0
Joined: Fri Jan 10, 2014 4:52 am

db service not working after upgrade

Post by Lux Smith »

Please take a look at the following screen shots. There are two pointer type attributes "criticals" and "backLog" which were not mapped in the create service, but they still show up in the payload. The error exception is that the id is not populated for the pointer type attribute.

Image

Image

Lux Smith
Posts: 0
Joined: Fri Jan 10, 2014 4:52 am

db service not working after upgrade

Post by Lux Smith »

Would really appreciate an update on this issue. Thanks

Alena Prykhodko
Posts: 0
Joined: Tue Apr 09, 2013 7:36 am

db service not working after upgrade

Post by Alena Prykhodko »

Hello Lux,

We are working on it and update as soon as have more information.

Evgene Karachevtsev
Posts: 12
Joined: Mon Apr 28, 2014 1:12 pm

db service not working after upgrade

Post by Evgene Karachevtsev »

Hello Lux,

Could you please show us a screenshot of the mapping for better understanding your issue?

Lux Smith
Posts: 0
Joined: Fri Jan 10, 2014 4:52 am

db service not working after upgrade

Post by Lux Smith »

It has been over 2 days and it is seriously impacting my deadline. Here is another screenshot. Would appreciate if you can reply promptly.

Image

Kateryna Grynko
Posts: 0
Joined: Thu Nov 15, 2012 9:13 am

db service not working after upgrade

Post by Kateryna Grynko »

Hi Lux,

Please share your app and database with a href="mailto:support@appery.io" rel="nofollow"support@appery.io/a and tell us what service to see? Could you please confirm you want to read data?

Lux Smith
Posts: 0
Joined: Fri Jan 10, 2014 4:52 am

db service not working after upgrade

Post by Lux Smith »

This is for updating data.

Yurii Orishchuk
Posts: 0
Joined: Fri Feb 14, 2014 8:20 am

db service not working after upgrade

Post by Yurii Orishchuk »

Hi Lux,

I've just tested your app and can not to reproduce your problem.

I see you have add correct JS to "main" field object with code:

pre

return "";

/pre

Does that fixed your problem?

If no - please specify steps to reproduce your problem in your app.

Thanks & Regards.

Post Reply