Min SDK version issue (Android-jquery mobile app)

This forum contains topics that were moved from Get Satisfaction
Ole Henrik Oftedal
Posts: 0
Joined: Thu Apr 19, 2012 4:52 pm

Min SDK version issue (Android-jquery mobile app)

Post by Ole Henrik Oftedal »

Hi :-)

I want to support older versions of Android phones in my app.

At the same time I will need the latest API to be able to upload to the Google Play Store (mandatory from Google and not an option).

To achieve this I need to select Library version 5.1 (the latest). Then I have to select
Min. SDK version = 7.0 (the lowest avaiable)
Target SDK version = 9.0 (the minmum from Google)

When I try to upload the APK file in Google Play developer Console I will succeed. However Google warns me that over 40% of devices wil not be compatible any more :-(

This is a high percentage. And some of the listed phone are like type Samsung Note 7 (made in 2016). I now that some of my customers will suffer from this so this is not a good situation to be in.

What to do? Please help!

Can you help me change to an older Min. SDK version before I start the APK build?

Best regards

Ole Henrik Oftedal
Support/Developer
Timeflex Systemer AS (Norway)
https://www.timeflex.no
https://www.timeflex.com

Serhii Kulibaba
Posts: 147
Joined: Tue Aug 27, 2013 1:47 pm

Min SDK version issue (Android-jquery mobile app)

Post by Serhii Kulibaba »

Hello,

This is a restriction by Google. Not possible to use the latest libraries version (it uses the latest Android SDK) with old devices. As a workaround, you can use the previous libraries version, which has the option to select lower Min SDK version

Ole Henrik Oftedal
Posts: 0
Joined: Thu Apr 19, 2012 4:52 pm

Min SDK version issue (Android-jquery mobile app)

Post by Ole Henrik Oftedal »

Hi and thankyou for quick reply.

"As a workaround, you can use the previous libraries version, which has the option to select lower Min SDK version"

No. I am sorry. The App Builder will prevent me. Because there is no way of selecting the latest Target version in dropdown menu when you have selected old Library.

Target SDK version = 9.0 (the minmum from Google)

Ole Henrik Oftedal
Posts: 0
Joined: Thu Apr 19, 2012 4:52 pm

Min SDK version issue (Android-jquery mobile app)

Post by Ole Henrik Oftedal »

Thank you so much. It worked fine :-) I have now placed app in Open Beta Tester program and we can start the testing now!

We are now on Libary 5.0 instead of 5.1.

Min. SDK version = 4.1 x (the lowest avaiable)
Target SDK version = 9.0 (the minmum from Google)

Cheers,

Ole.

maykohli0503
Posts: 1
Joined: Fri Apr 02, 2021 6:34 am

Re: Min SDK version issue (Android-jquery mobile app)

Post by maykohli0503 »

Actually sometime older apps or their versions does not support in android so check it

Post Reply